Parigot

“Parigot”

Share



Lenguaje no verbal, hombres y mujeres

Vía Washington post

Share



Problema al actualizar PHP 5.3 – XCache requires Zend Engine API version

Al actualizar PHP desde una reposición, por ejemplo de la 5.2.* a la 5.3.*, la extensión de XCache queda desactualizada.

Para verificarlo simplemente tienes que hacer.

php -v
#Obtenemos de vuelta
XCache requires Zend Engine API version 220060519.
The Zend Engine API version 220090626 which is installed, is newer.
Contact mOo at http://xcache.lighttpd.net for a later version of XCache.

Para solucionarlo vamos a recompilar XCache.

#Nos movemos al directorio
cd /usr/local/src
#Obtenemos la última versión XCache 1.3.2
wget http://xcache.lighttpd.net/pub/Releases/1.3.2/xcache-1.3.2.tar.gz
#Descomprimimos
tar -zxf xcache*.tar.gz
#Nos movemos al source
cd xcache*
#Verificamos
phpize
#Creamos y nos movemos a otro directorio para compilar
mkdir ../xcache-build
cd ../xcache-build
#Configuramos
../xcache-1*/configure -enable-xcache
#Compilamos
make
#Instalamos
make install
#Verificamos
php -v
#Reiniciamos apache 
service httpd restart

Share